etc

C/C++ 확장이 설치되어 있어야 합니다. VSCode 설정(Ctrl + ,)에서 Clang_format_style 검색 Clang_format_style에 { IndentWidth: 4, ColumnLimit: 0 } 입력 Clang_format_fallback Style에 Google 입력 (기본적으로 Google 스타일에서 들여쓰기 4칸, 한 줄 최대 글자 수 제한 없음으로 설정하겠다는 의미)
Installation Setup 우분투에는 죽어도 안 깔리니까 삽질하지 말고 칼리에 설치하자.. sudo apt update -y sudo apt upgrade -y sudo apt dist-upgrade -y sudo apt install openvas -y sudo gvm-setup sudo gvm-setup을 실행했을 때 $ sudo gvm-setup [sudo] password for kali: [>] Starting PostgreSQL service [-] ERROR: The default PostgreSQL version (14) is not 15 that is required by libgvmd [-] ERROR: Use pg_upgradecluster to update your Postg..
Build Dockerfile이 있는 디렉토리에서 작업 docker build . 만약 Dockerfile의 파일명이 Dockerfile이 아닐 경우 docker build . -f Run 빌드된 이미지의 ID 확인 docker image ls Container 생성 docker run 968949c876df & docker container ls Have fun Bash 셸을 열어서 Docker 환경에서 작업 가능 docker exec -it awesome_cannon /bin/bash 특정 유저로 접속하고 싶으면 -u 옵션 사용
Ubuntu 16.04에서 apt install python3-pip로 pip를 설치하면 아래의 오류가 발생한다. $ pip Traceback (most recent call last): File "/home/h0meb0dy/.local/bin/pip", line 7, in from pip._internal.cli.main import main File "/home/h0meb0dy/.local/lib/python3.5/site-packages/pip/_internal/cli/main.py", line 57 sys.stderr.write(f"ERROR: {exc}") ^ SyntaxError: invalid syntax pip가 Ubuntu 16.04의 파이썬 버전인 3.5에 호환되지 않아서 발생하는 오류..
homeb0dy
'etc' 카테고리의 글 목록 (2 Page)